
Introduction to GIS 

Lab02 GIS Visualization Exercise 1 – Field Calculation in ArcGIS  

Objectives of this exercise: 

To learn how to create and calculate a new field and calculate geometry in a table with 

ArcGIS Pro 

• Create a new field 

• Calculate geometry 

• Calculate field 

 

To complete exercises, you need the following: 

• ArcGIS Pro 3.3.1 (Basic, Standard, or Advanced) 

 

The data needed for this exercise are under the folder Lab 02, named as Lab02Data.zip 
(download and unzip it to your own folder). 

 
Exercise 1 Demonstration Video: 

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=d37ce87c-8349-472c-a870-
ae85001c20ec  

 

Create a new ArcGIS project 

1. Start ArcGIS Pro and sign in if necessary.  

2. On the start page, under Blank Templates, click Map. The Map template creates a new project 

containing a 2D map.  

 

3. For the New Project dialog box, by default, projects are created in your <User 

Documents>\ArcGIS\Projects folder. To save a project to a different location, click the Browse 

button  and browse to the folder you want. Name the project IntroToGIS_Lab02. 

  

4. Click OK. The new project opens with a map view showing a topographic basemap centred on 

Singapore.  

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=d37ce87c-8349-472c-a870-ae85001c20ec
https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=d37ce87c-8349-472c-a870-ae85001c20ec


Create a folder connection and add data 

5. In the Catalog pane, right-click Folders and choose Add 

Folder Connection. Create a folder connection 

to ...\Lab02Data (the folder that contains the data for this 

lab). Expand folders and see what data we have.  

6. Add the files by dragging them to the map one by one:  

 

Region_Census2010.shp, 

Planning_Area_Census2010.shp  

Subzone_Census2010  

 

7. Open the attribute table. In the Contents pane, right-click Subzone_Census2010 and choose 

Attribute Table. Now you will see the attributes of features in Subzone_Census2010. 

 

8. Take a few minutes to explore the attributes of the above three layers. After that, close all 

attribute tables. 

 

Create a new field in the attribute table 

9. In the Catalog pane, drag the Subzone_2010_Joined file under Census 2010.gdb to the map. 

10. In the Contents pane, right-click Subzone_2010_Joined and choose Attribute Table. Now the 

Attribute Table is opened. 

11. On the Attribute Table, click Add , we can define the name and data type of the new field. 

 

12. Type in Pop_Den_New (representing the population density) as the Name and Alias and choose 

Double as the Data Type. Choose Numeric as the Number Format (keep the default settings 

unchanged). 



 

13. In the Fields tab on the ribbon, click  to save the newly created field. 

14. In the Fields tab on the ribbon, click  to create another new field with the Name and Alias of 

Area_SQKM_New, and the Data type of Double. 

15. Click  to save the newly created field. 

16. Click × to close the dialog box of adding field. 

 

 

Calculate the geometry of features 

17. Return to the Subzone_2010_Joined attribute table. Right-click the 

newly created field Area_SQKM_New, and choose Calculate 

Geometry. You will see that the Calculate Geometry dialog box 

opens. 

18. In the Field (Existing or New) drop-down list, Area_SQKM_New is 

selected automatically. From the Property drop-down list, choose 

Area. From the Area Unit drop-down list, choose Square 

Kilometers. In the Coordinate System box, select Current Map 

[Map] from the dropdown list, and then the Projected Coordinate System for Singapore, SVY21 

will be selected automatically. You will revisit the concept of Coordinate Reference Systems in 

the subsequent lectures and labs. 

 

19. Click OK. you will see that the area is calculated in square kilometres for each row. 



Calculate field 

20. In the attribute table, right-click the newly created field Pop_Den_New, and choose Calculate 

Field.  

21. In the Calculate Field dialog box, type in (or by double clicking the fields and operation signs) 

the expression below: 

!total! / !Area_SQKM_New! 

22. Click Apply. And you will see the Pop_Den_New field is calculated automatically. Once the 

Pop_Den_New Field has been calculated, press “OK” to close the dialog box. 

23. Save your project as IntroToGIS_Lab02_Exercise01. 

 



Introduction to GIS  

Lab02 GIS Visualization Exercise 2 – Choropleth Mapping  

 

Objectives of this exercise: 

 

• To learn how to design thematic maps using ArcGIS Pro 

 
To complete exercises, you need the following: 

 

• ArcGIS Pro 3.3.1 (Basic, Standard, or Advanced) 

 

The data needed for this exercise are under the folder Lab 02 
 

Exercise 2 Demonstration Video: 

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=7ff37617-b1bd-4c98-93d4-
ae9a008834df  

 

In Exercise 01, you have calculated the population density of different subzones of Singapore in 

2010, which is the basis of choropleth mapping. Open IntroToGIS_Lab02_Exercise01.aprx and 

then save the project as IntroToGIS_Lab02_Exercise02. 

Set the parameters for choropleth mapping 

1. In the Contents pane, right-click on the Subzone_2010_Joined, 

and choose Symbology. Now you should see the Symbology 

pane on the right. 

2. In the Symbology pane, under Primary Symbology  tab, in 

the Primary symbology drop-down list, choose Graduated 

Colors. 

3. Regarding Field, choose Pop_Den_New as the value. 

4. Regarding the classification Method, use the default Natural 

Breaks (Jenks).  

5. Choose 6 as the number of Classes  

6. In the Color scheme drop-down list, click Show name box and 

choose Yellow to Red color. 

7. Turn off the following layers by unticking the boxes on the left 

side of the layer names. 

• Subzone_Census2010 

• Planning_Area_Census2010 

• Region_Census2010  

 Think about how to reduce the number of decimal places on the 

Label. 

 

 

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=7ff37617-b1bd-4c98-93d4-ae9a008834df
https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=7ff37617-b1bd-4c98-93d4-ae9a008834df


Insert a layout 

8. On the ribbon, click the Insert tab. In the Project group, click New 

Layout to show page size and orientation options. Choose ISO – 

Landscape A5 148 × 210 mm. A blank layout appears in the map 

area.  

Insert a map frame 

9. Under the Insert tab, Click Map Frame button. Choose Map → 1: 256,778 (the ratio may be 

different).  

 

10. Click your mouse at any location on the blank layout. And you will see a map falls on the 

blank layout. Now you can adjust the size of the map and move it in the layout. 

11. In the Contents pane, right click Map Frame under the tab of 

Layout, and choose Activate. 

 

12. On the ribbon, under the Map tab, ensure that the Explore tool 

 is active. Pan and zoom the map to an extent that you 

would like.  

13. On the ribbon, in the Layout tab, click the Close Activation 

 button. Now you will return to Layout editing mode. 

 

Insert map elements 

Next, we will add map elements including a legend, a north arrow, a title, and a scale bar to the 

layout. The legend explains the map’s symbology. The north arrow indicates the direction of 

north. The scale bar provides a visual indication of the size of features. The title describes the 

main contents of the map. 



14. Insert the title. On the ribbon, under the Insert tab, in the Graphics and Text group, find 

Rectangle text , and choose the Rectangle text .  

 

15. Click your mouse at the top on the blank layout, you will see the text box. In the text box, 

type in the title of your own map (e.g., Singapore Population Density Map). Right-click the 

text box and select Properties. Now the font name and font size can be modified in the Text 

pane on the right. 

16. Insert the legend. On the ribbon, under the Insert tab, in the Map Surrounds group, click 

Legend .  Think about how to change the field name in the legend from 

Pop_Den_New to one that is more readable. 

17. Click your mouse at any location in the mapping area. Resize the legend and move it to a 

suitable place in the layout. The properties of the legend can be modified in the Legend pane 

on the right (can be opened by right-clicking the legend and selecting Properties). 

18. In the Contents pane, under Layout → Legend, ensure that you have unchecked the boxes of 

all layers except the Subzone_2010_Joined layer. In the Legend pane on the right, click on 

Legend Items→Show properties, the [multiple items] pane appears, and uncheck the Layer 

name box. 

19. Insert the North Arrow. On the ribbon, under the Insert tab, in the Map Surrounds group, 

click North Arrow . 

20. Insert the Scale Bar. On the ribbon, under the Insert tab, in the Map Surrounds group, click 

Scale Bar .  

 

21. After the scale bar has been inserted, right-click the scale bar and select Properties. In the 

Scale Bar pane on the right, change the Map Units from Miles to Kilometers (if not in 

Kilometers), abbreviated to KM in the Label Text. Resize the length of the scale bar to 10 

KM. You will see the layout as follows. 



 

Export the layout 

Once the layout is finished, we can print it or export it to a file. The export file would generally 

have higher quality than the screenshot. 

22. On the ribbon, click the Share tab. In the Output group, click Export Layout  The Export 

Layout pane appears. 

23. Click the File Type drop-down menu and choose JPEG (*.jpg). 

24. Browse to the location where you want to save the file and type in a name you like in the 

Name box. 

25. Set the Resolution as 300 DPI. It is common that published papers require the resolution of 

colour figures at least 300 DPI. 

26. Click the Export button. The layout is saved on the disk and you can open it now. 

Q-1 Continuing from the steps above, please design a professional (with appropriate and necessary 

map elements) and aesthetically pleasing choropleth map. Export the map to a Tiff file (300 dpi) and 

insert the map into your Word document (3 marks). In addition, please identify the subzone with the 

lowest population density and provide its name and value (1 mark). 

(Notes: A page layout (often referred to simply as a layout) is a collection of map elements 

organized on a virtual page designed for map printing. Common map elements include one or more 

map frames (each containing an ordered set of map layers), a scale bar, a north arrow, a map title, 

descriptive text, and a legend. For geographic reference, you can add grids or graticules.  



Once added to a layout, elements can be selected, moved, and resized on the layout to achieve the 

desired look and feel. This behavior can be turned off by locking an element, preventing selection, 

moving, or resizing interactively on the layout. Switch between locked and unlocked views by 

clicking the Lock button next to the element in the Contents pane.  

Layouts can have a landscape (wide) or portrait (tall) orientation. They can be exported and used 

electronically and also printed. The page size varies depending on the specifications for the output. 

What you see on the layout is what you will get when you print or export the map to the same page 

size.  

A page layout can also be used to author pages of a map book. If your map has multiple pages, 

consider using a map series.  

More information can be found at this link: https://pro.arcgis.com/en/pro-

app/latest/help/layouts/layouts-in-arcgis-pro.htm) 

Q-2 Please design a Graduated Symbol map based on the Subzone_2010_Joined layer with 

appropriate and necessary map elements. This map should reflect the populations of elderly people 

(aged 50 and above) for different subzones in Singapore. Export the map from the layout view to a 

Tiff file (300 dpi) and insert the map into your Word document (3 marks). In addition, please identify 

the subzone with the highest number of elderly people and state its name and value (1 mark). 

Note that the demographic information is included in the attribute table. For example, the field a2024 

refers to the number of people whose ages are between 20 and 24. 

https://pro.arcgis.com/en/pro-app/latest/help/layouts/layouts-in-arcgis-pro.htm
https://pro.arcgis.com/en/pro-app/latest/help/layouts/layouts-in-arcgis-pro.htm


Lab02 GIS Visualization Exercise 3 – Other visualization techniques  

 

Objectives of this exercise: 

To learn how to design a heat map using ArcGIS Pro 

 

To complete exercises, you need the following: 

• ArcGIS Pro 3.3.1 (Basic, Standard, or Advanced) 
 

The data needed for this exercise are under the folder Lab02Data 

 

Heat map symbology draws point features as a dynamic, representative surface of relative density. 

Use heat map symbology when you have many points that are close together and cannot be easily 

distinguished. Another characteristic of a heat map is that it is a continuous representation of density 

while point features can only represent discrete values. 

Since heat mapping is a representation of point distribution, it works best when there is a large 

number of point features, especially if their symbols overlap. When you have sparse distributions of 

points, consider drawing them with a different symbology option instead. 

 

Create a heat map 

1. Open the IntroToGIS_Lab02_Exercise02 and save it as IntroToGIS_Lab02_Exercise03. 

2. Go to the Map view by clicking . 

 

3. In the Contents pane, turn off all the layers except World Topographic Map and World 

Hillshade. 

4. In the Catalog pane, expand the folder Eldercare_Centers, and drag the ELDERCARE.shp 

file to the map area. Now you will see the distribution of eldercare centers in Singapore as 

below. Each point represents one eldercare center. 



 

5. In the Contents pane, right click the ELDERCARE layer and choose Symbology. 

6. In the Symbology pane on the right, click the Primary symbology drop-down list, and 

choose Heat Map. The heat map displays, which represents the density of points. 

 

7. On the ribbon, click the Feature Layer tab, In the Effects group, set the Layer Transparency

 as 65% by typing in the number in the box on the right. 

8. In the Visibility Range group, click the drop-down arrow next to Scale Range , and click 

1:50,000 to set the maximum scale for the heat map. Note that zoom-in will result in a larger 

scale and zoom-out will result in a smaller scale. The scale of the view is shown in the 

bottom-left corner of the map view.  

9. At larger scales (≥1:50,000), the pattern is too local and the heat map disappears. 



 

10. Zoom to explore the map, and pay attention to the change of the display scale. 

11. Save the project. 

Change symbols 

12. In the Contents pane, turn on the Region_Census2010 layer. Right-click the layer to choose 

Symbology. If it is not in the Contents list, add the data first. The Symbology pane on the 

right appears.  

 

At the top of the pane, the Primary symbology  tab is selected. The default Primary 

symbology method is Single Symbol, which means that all 

features in the layer are drawn with the same symbol 

(color, shape). 

13. In the Symbology pane, next to Symbol, click the symbol 

patch  (the color may look different). The pane changes 

to show symbol formatting options. 

14. Under Gallery, in the search box, type in extent 

transparent, and press Enter. A total of 6 symbols are 

found. 

15. Click the Extent Transparent Wide symbol to select it.  

16. At the top of the pane, click the Properties tab. 

The Properties tab has three graphical tabs under it. On the Symbol  tab you can change 

properties of the symbol. For example, you can change the fill color, outline color, and outline 

width of a polygon symbol. 

17. Click the Layers  tab.  

On this tab, you can change the properties of the graphical elements, or symbol layers, that 

comprise the symbol. This gives you more control over the symbol's appearance. This symbol 

is composed of two symbol layers: a stroke and a fill. 



18. Click the Structure  tab.  

On this tab, you can change the symbol's structure by adding and removing symbol layers. 

You can also apply effects. In this case, you'll add a donut effect to the fill layer. The donut 

effect restricts the gray fill to a ring at the edge of the polygon. The interior is transparent, like 

a donut hole. 

19. Under Appearance under the Symbol tab , ensure that the 

Outline color is Black and change the Outline width to 2 pt. 

20. In the Structure tab , under Symbol, click Add effect. On the 

drop-down menu, choose Donut. Click the Apply button at the 

bottom, you will see the effect of Donut. 

21. In Content Pane, turn on the Planning_Area_Census2010 layer, 

and adjust the order of the layer if necessary so that the 

Planning_Area_Census2010 layer serves as the background. 

You should see the heat map of eldercare centers as below (the 

color may look different). In the Contents pane, move the 

Region_Census2010 layer to be above the 

Planning_Area_Census2010 layer if you do not see the bold 

boundaries within Singapore. 

 

 

Heat map symbology displays the relative density of points as a dynamic raster visualization using a 

color scheme to indicate density values. Ideally, the color scheme is a smoothly varying set of colors, 

ranging from cool (sparse density of points) to hot (high density of points). The density definition, and 

therefore the color values, change as you zoom in and out. The density is calculated using the kernel 

density method, the same algorithm used by the Kernel Density geoprocessing tool. 

As can be seen from the heat map, eldercare centers are mostly clustered in the south part. However, 

in the west part of Singapore, there are few eldercare centers. 


