
Introduction to GIS 

Lab04 Geodatabase Development and Spatial Editing 

Exercise 01 – Creating a GIS Database using Geodatabase Format 

This section covers screen digitization of a geo-rectified image. Digitization is a GIS data input 

method that transforms data from either a raster image or a paper map into vector form. An online 

base map will be used to create three feature classes using the Geodatabase data format. 

To complete exercises, you need the following: 

• ArcGIS Pro 3.3.1 (Basic, Standard, or Advanced) 

Video Demonstration: 

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=f252f83b-6fca-496b-a064-

aec200236436   
 

1. Start ArcGIS Pro and sign in if necessary. Click Map and create a new project 

IntroToGIS_Lab04_Exercise01. 

2. In Catalog Pane, navigate to your working folder. Right-click the folder and select New → File 

GeoDatabase. Rename the new Geodatabase as 

IntroToGIS_Lab04_Exercise01_Database.gdb. 

3. Next, we will create feature classes of various geometry types (i.e., point, polyline, and polygon). 

Below are instructions for creating new feature classes in ArcGIS Pro. 

4. Create a road (polyline) feature class. Right-click the Geodatabase you created, and choose New 

→ Feature Class. In the Create Feature Class pane on the right, enter the following 

information. 

Page 1/6 Name  major_road  

Alias  Major Road  

Type  Line 

Page 2/6 New data field  Name (use Text as the data type)  

Page 3/6 XY Coordinate system  Select “SVY21 Singapore TM” 

Note: Choose Line for Feature Class Type, and use default settings for the remaining items. 

Click Finish. You should find a new feature class named major_road under the geodatabase. 

5. Create a building (polygon) feature class. Right-click the Geodatabase you created, and choose 

New → Feature Class. In the New Feature Class pane on the right, enter the following 

information. 

Page 1/6 Name  building 

Alias  Building 

Type  Polygon 

Page 2/6 
New data field  

Name (use Text as the data type)  

Type (use Text as the data type) 

Page 3/6 XY Coordinate system  Select “SVY21 Singapore TM” 

Note: Choose Polygon for Feature Class Type, and use default settings for the remaining items. 

Click Finish. You should find a new feature class named building under the geodatabase. 

6. Create a POI (point) feature class. Right-click the Geodatabase you created, and choose New → 

Feature Class. In the New Feature Class pane on the right, enter the following information. 

Page 1/6 Name  poi 

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=f252f83b-6fca-496b-a064-aec200236436
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Alias  Point of Interest 

Type  Point 

Page 2/6 New data field  POI_Type (use Text as the data type)  

Page 3/6 XY Coordinate system  Select “SVY21 Singapore TM” 

Note: Choose Point for Feature Class Type, and use default settings for the remaining items. 

Click Finish. You should find a new feature class named poi under the geodatabase. 

7. The above steps allow you to create feature classes with the chosen geometry types. These feature 

classes are “empty” at the moment – there are no roads, buildings or POI points in these feature 

classes. Next, we will populate the feature classes with data by digitalizing images on screen. We 

will use NUS campus image to digitize major roads and buildings. 

8. On the ribbon, in the Map tab, click Basemap and choose Imagery. Zoom in to FASS in NUS, 

Singapore. 

   

9. Add the Building and road feature classes to the map (if 

you do not see them in the Contents pane on the left). 

10. Click on the Edit tab on the ribbon, and click on Create. 

A Create Features panel will pop up on the right. In 

this panel, make sure you select “Major Road”.  

11. The cursor should change to a crosshair. Use this tool to 

digitize roads in NUS by following the center line of the 

roads. Note that you are using the point mode digitizing 

method – “you need to click at every turn of a line.” 

⚫ If two roads connect to each other, you have to make sure that they are connected in the 

sense that a node should exist at the location where the two roads intersect. 

⚫ Digitize the roads on the following map. Each time you finish a line, double-click to confirm 

it and start a new line (same for the polygon below). After finishing all the lines, click Save 



 on the Manage Edits group under the Edit tab. Also, remember to save your project 

frequently. 

 

12. Now you need to add the road names to the Roads feature class. In the Contents pane, right-click 

on major roads, and choose Attribute Table. The Name field is currently null. You can fill in the 

road names by double-clicking the box. You can refer to Google Maps or a pre-existing NUS 

campus map for this information. Make sure to click Save under the Edit tab to save your edits. 

13. In the Contents pane, select major roads. On the ribbon, click the labeling tab, and make sure 

Label  is activated. Check Label Features In This Class box, and select Name in the Field 

drop-down list. Now the road names should appear on the map (change the Text Symbol Color to 

yellow if you cannot see the names). 

14. Next, we will proceed to digitize the buildings in FASS. Following the instructions in the above 

steps. Enter the name of each building (please digitize at least 5 building polygons). 



 

15. Next, we will proceed to digitize the point facilities in FASS. Following the instructions in the 

above steps, digitize at least 5 points (e.g., ATM, canteen, coffee shops) in FASS. Enter the name 

of each POI in the attribute table. 

Q-1. Create and design a FASS map with roads, buildings, and POIs and export it from layout 

view to a Tiff file (300 dpi) with appropriate map elements. Insert the map into your Word 

document. (3 marks) 

 

Notes: 

Explore to make good use of the symbology for POIs, such that they are represented by easily 

recognizable symbols. Hint: Use Categorized Symbology (with POI_Type as the Value) and 

Pictographic Symbols such as for ATM and for coffee shops to distinguish the POIs. 

 



Introduction to GIS 

Lab04 Geodatabase Development and Spatial Editing 

Exercise 02 – Using Geodatabase Topology to clean up data 

Objectives of this exercise: 

To practice how to use geodatabase topology to clean your data in ArcGIS Pro 

To complete exercises, you need the following: 

• ArcGIS Pro 3.3.1 (Basic, Standard, or Advanced) 
The data needed for this exercise are under the folder Lab04 

Video Demonstration: 

https://mediaweb.ap.panopto.com/Panopto/Pages/Viewer.aspx?id=93791e9f-d609-40cf-

b8b5-aed1008f050f   
 

I. Creating a topology rule for a single feature class 

1. Start ArcGIS Pro and sign in if necessary. Click Map, and create a new project. Name the project 

IntroToGIS_Lab04_Exercise02. 

2. In the Catalog pane, right-click Folders and choose Add Folder Connection. Create a folder 

connection to the Lab04Data folder. 

3. Expand the folder, and you will find a StudyArea feature dataset. Right-click on it and choose 

New → Topology. A dialog appears. 

 

4. In the dialog box, check Lotlines to indicate that you want to apply the topology rule to the 

features in the LotLines feature class. Accept the default topology name and cluster tolerance. 

Click Next. 

5. On the next page, click Add , then click on the blank cell under Feature Class 1, and a 

dropdown list will appear. Choose LotLines. Click on the blank cell under Rule, and choose Must 

not have Dangles (Line). Click Next. The rule is now added to the list of topology rules. 
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6. Accept the default Topology Name, XY cluster Tolerance and Number of XY Ranks. Click 

Finish. This concludes the steps of creating a 

topological rule in the geodatabase. Refresh the 

StudyArea feature dataset if you do not see it. 

 

II. Finding topology errors 

7. In the Catalog pane, drag StudyArea_Topology to 

the map area (refresh the Lab04Data.gdb database 

or the StudyArea feature dataset if you cannot find 

the StudyArea_Topography). It will also appear in 

the Contents Pane. 

8. In the Contents Pane, select LotLines, and Zoom to 

Layer. 

9. On the ribbon, under the Edit tab, click  Error Inspector to open the Error Inspector 

window. Click Validate ( ) to validate the topology. The result is shown below. 

 

Note: By clicking Validate, it will only identify topological errors on layers in the current map 

extent. So you need to make sure that the current map extent contains all the features of the 

LotLines layer. 



The topology layer shows all topology errors. The StudyArea_Topology has one feature class 

(LotLines) and one rule (must not have dangles), so all topology errors seen in ArcGIS Pro are 

related to the specific rule. The geometry for error dangles is point, located at the dangling end of 

a line feature. All of the red features on the map are dangles. 

10. Click the Modify ( ) button in the Features group under the Edit tab. The Modify Features 

pane appears on the right. 

11. Open the Attribute Table of LotLines. Click on the record with OBJECTID of 144, and choose 

Zoom To. You will find an overshot error on the line. Close the Attribute Table. 

12. In the Error Inspector window, select the LotLines 144 record 

(note that the default filter is Map Extent. Therefore, make sure 

that LotLines 144 is completely shown in the map area). On the 

right of the Error Inspector window, click the Fix tab 

(enlarge/expand the Error Inspector window if you do not see the 

Fix tab), and choose Trim (enlarge/expand the Error Inspector 

window if you do not see the Trim tool). In the pop-up dialog 

box, type “3” m and press Enter. The dangling segment is 

trimmed to where the lines intersect, and the error disappears 

from the window. Click Save under the Edit tab to save edits. 

Also, save the project. 

Note that the parameter of 3m means that if the dangle is less than 3m far from the intersection, 

the dangling segment will be trimmed. It also means that if the distance is larger than 3m, we 

would not consider it as a dangle. 

 

13. Apply the above method to the feature 180. However, the feature 180 is with an error of 

undershoot. Therefore, we cannot use Trim to fix this error. 



 

14. We will use another approach to fix this error. In the Error Inspector window, right-click the 

LotLines 180 record and choose Extend. In the pop-up Maximum Distance dialog box, type “3” 

m and press Enter. Click Save under the 

Edit tab to save edits. Also, save the project. 

15. Select and Zoom to Feature 182. The line 

feature is with the dangle flashes (see the figure 

on the right. Keep zooming in until you can see 

two parallel lines). This represents a double 

digitization error (the same feature being 

digitized twice). 

16. To fix this error, we can just delete this line. 

17. Select Feature 182, then click the Delete button 

under the Edit tab. The extra line is deleted. 

Click Save to save edits. Also, save the 

project. 

 

So far you have learned how to correct three topological errors: trim, extend, and delete. When 

you perform such a task, the topology tracks where changes have been made. These places are 

called dirty areas as new errors could be potentially created by the editing work just performed. 

These new errors will not be discovered until the dirty area is validated again (and dirty areas will 

be cleared after being validated). 

18. In order to see the dirty areas, check Dirty Areas in the Contents pane. The dirty areas are shown 

on the map. They cover the features that you have just edited. The use of dirty areas optimizes the 

validation process, as only dirty areas instead of the whole area must be checked for topology 

errors. 



 

Question 2: The feature Lotlines 968 has been identified as an error according to the rule set above 

(Must not Have Dangles). How will you handle this error? (2 marks) 

III. Fixing multiple errors at once 

19. Ensure that the Error Inspector Error window remains open. Deactivate the Map Extent  

Filter so that all errors are shown in the table. Select all error records in the table by using “shift” 

key (or “Ctrl + A”). 

 

 

20. In the Modify Features pane on the right (if you do not see the pane, on the ribbon, click Modify 

under the Edit tab), click Fix Error  under Validate group. Click the Fix tab in the Error 

Inspector window. 

 

21. First, fix the undershoot errors. Click Extend. Set the Maximum Distance as 3 m. Press Enter. 

The process may take a few seconds while all of the features with dangles are checked to see if 

there is a feature within three meters that they can be extended to. A number of dirty areas will 

appear on your map. 

22. Repeat the above step to fix other errors (try extent, trim, and then snap, setting the maximum 

distance/snap tolerance as 3m, repeat the steps several times until no error can be batch fixed in 

the Error Inspector Error window, click Validate  to see if you have amended all errors in 

the dataset (you will see some errors left unfixed as the batch processing cannot fix all of them). 



 

23. Save the editing under the Edit tab, and save the project under the Project tab. 

 

IV. Adding Feature Classes and Rules into Topology 

Now you will create a new polygon feature class from the Lotlines feature class that you have been 

working on and from the LotIds (point) feature class that will provide the attributes of the new lot 

features. 

24. Now you will practice adding feature classes to the topology. In the Catalog pane, expand the 

StudyArea feature dataset to see all feature classes and the topology file StudyArea_Topology. 

Right-click StudyArea_Topology and choose Properties. The Topology Properties dialog 

appears. 

25. Click the Feature Class tab. Under the Feature Classes table, make sure LotLines is checked. 

Check both LotIds and Lots. Click OK. 

Just now, two feature classes have been added to the topology. They are now ready for topology 

rules. 

26. This step involves adding topological rules that enable us to identify potential errors with the Lots 

feature class. 

• Right-click StudyArea_Topology and choose Properties. The Topology Properties dialog 

appears again. 

• Click the Rules tab, and then click “Click here to add a new rule”. Click the blank cell 

under Feature Class 1 and choose LotIds from the drop-down list. Choose Must Be 

Properly Inside (Point-Area) as the Rule and Lots as the Feature Class 2. 

• Click “Click here to add a new rule” to add one more rule. Choose LotLines as Feature 

Class 1, and choose Must Be Covered By Boundary Of (Line-Area) as the Rule and Lots as 

the Feature Class 2. Click OK. 

Two more topology rules have just been added to the topology to impose constraints on 

spatial relationships between feature classes. 



 

27. Now you will examine the revised topology in ArcGIS Pro and continue cleaning up your data. 

Drag LotIds and Lots feature classes to the Contents Pane. 

28. Open the Error Inspector Window if it is not open (click Error Inspector under the Edit tab on 

the ribbon). Click Validate. 

  

The red lines represent a new type of topology error. 

29. Open the Attribute Table of LotIds, and zoom in to LotIds 

feature with OBJECTID 1119. Close the Attribute Table. The 

two red lines beside LotIds 1119 (see the figure on the right) have 

violated the rule of “Must Be Covered By Boundary Of”. 

30. There should be two types of errors that can be found on point 

features. The first one is to violate the rule of “Must Not Have 



Dangles”, which you are already familiar with. However, in Section III, this topology error is not 

completely amended yet. The second one is to violate the rule of “Must Be Properly Inside”. 

31. In This step, we will try to fix the LotIds 1119 error. In the Error Inspector window, select the 

record Lotlds 1119. In order to quickly find this record, you can activate the Map Extent  

again. On the right, click the Fix tab. Click Delete Feature to fix the error. 

 

32. On the ribbon, under the Edit tab, click the Snapping  

button to ensure “snapping” is enabled. 

33. In this step, you will fix the error of the two red lines. That is, 

please solve the problem of “Must Not Have Dangles” for 

Lotlines 1507 and Lotlines 1514 (Hint: Try Trim and/or Edit 

Vertices under the Reshape group in the Modify Features 

pane; Click Validate in the Error Inspector Window if you 

do not see any change after editing). The result is shown 

below. 

   

 

 

 

 

 

34. Now you should be able to see the new “lot”, but there is no polygon for this “lot”. Now the new 

polygon can be constructed. 

35. Click the Construct Polygon button under the Construct 

group in the Modify Features pane. Select the four lines that 

form the new polygon lot (you can select multiple items by 

pressing Shift), accept all the default values and click 

Construct. A new lot polygon feature is created. 

36. Click Validate in the Error Inspector Window, and you 

will find the two red lines disappear. Save your edits and save 

the project. 



 

37. Now we will shift our attention to a problem caused by undershoot dangle error. Zoom to 

LotLines 1842 (see figure below). The line in the middle should cut the polygon into two. 

However, due to the undershoot dangle error, the parking lot is only one polygon. We are going to 

use another method to fix this error. 

             

38. In the Modify Features pane, click Extend or Trim  under Reshape group. The tool works 

differently from the Extend tool to fix the topology error. Rather than specifying a distance, you 

select a feature to which the tool will extend a line. Click on the error point and then click on the 

lot line that you want to extend to. Click Validate in the Error Inspector Window, and you will 

find that the dangle point disappears. Save the edit. 

39. Although the undershot line was extended, the lot 

polygon is still not divided yet. Now we will split 

the polygon by the lot line. In the Modify Features 

pane, click Split  under Divide group. Click the 

By Feature tab. Under the Input Features tab, 

select both the lot polygon and the splitting line 

(use shift). Place the LotLines layer at the top of the 

Contents pane if you do not see the line in the 

middle. Under Target Features, select only the lot polygon. Click Split. 

40. Click on the polygons on the two sides of the splitting line to check if the polygon has been split 

or not. 



 

Question 3. What are the areas of the two polygons, respectively? (2 marks) 


